EOL: PHP 5.6 und 7.0 auf Uberspace 7

Alte Versionen gehören bei PHP leider zum Alltag. Während es natürlich viele schicke, moderne PHP-Apps gibt, stolpern wir hin und wieder über Kleinkrams, der doch bitte gerne PHP 5.4 hätte. Auch 5.6 wird noch häufig gefordert. Dennoch müssen wir hier - der Sicherheit wegen - Zöpfe abschneiden.

Wie bei php selbst und auch in unserem Manual dokumentiert, laufen die PHP-Versionen 5.6 und 7.0 dieses Jahr aus. Danach gibt es keine Updates mehr, auch nicht für Sicherheitslücken. Die beiden Version fliegen demnach bei Uberspace 7 mit dem 31.12. raus. Da wir standardmäßig die Version 7.1 einstellen, sind von der Änderung nur User betroffen, die explizit eine alte Version eingestellt haben: 96 Stück bei PHP 5.6 und nur 37 bei 7.0.

PHP-Version umstellen

Die PHP-Version lässt sich mit einem einzigen Befehl umstellen; Details dazu finden sich im Manual. Achte vorher drauf, dass die laufende PHP-App auf dem neuesten Stand ist oder stelle veraltete Software auf zeitgemäßere Äquivalente um. Danach kann die Version auf 7.1 (oder besser 7.2) angepasst werden:

[eliza@dolittle ~]$ uberspace tools version use php 7.1
Selected PHP version 7.1
The new configuration is adapted immediately. Patch updates will be applied automatically.
[eliza@dolittle ~]$ uberspace tools version show php
Using 'PHP' version: '7.1'
[eliza@dolittle ~]$

Wenn du deine PHP Version nicht umstellst, erledigen wir das für dich am 31.12. Es gibt danach keine Möglichkeit auf 5.6 oder 7.0 zurückzustellen.

Wir wünsche eine flotte Migration!

EOL: PHP 5.6 und 7.0 auf Uberspace 7
Share this