/ updates php

Neue PHP-Versionen mit neuerer ICU4C

Wir haben mal wieder einen Schwung PHP-Updates verteilt und hätten damit nun auf allen Hosts:

  • 5.6.3 (Default für neue Uberspaces)
  • 5.5.19
  • 5.4.35

Infos, wie die Versionen für den eigenen Account aktiviert werden können, finden sich im Wiki.

Die 5.3er-Serie ist mit 5.3.29 nebenbei offiziell end of life; wer die noch einsetzt, sollte sich schleunigst mal auf die Todo-Liste setzen, auf eine neuere Version zu migrieren. Auf neuen Hosts werden wir aller Voraussicht nach nur noch Versionen ab 5.4 aufwärts bereitstellen.

Ab diesen Releases nutzen wir anstelle der inzwischen doch recht betagten ICU4C 4.2.1 (CentOS 6) bzw. 3.6 (CentOS 5) die deutlich neuere Version 50 (betrifft die intl-Extension). Probleme erwarten wir dabei nicht; falls doch, kann als Quick-Fix problemlos wieder auf das vorherige Release gewechselt werden. Wir freuen uns dann auf entsprechende Bugreports unter hallo@uberspace.de.